今日股市行情,找股票内参,学股票炒股入门基础知识

股票怎么玩

您当前的位置:>首页 -> 股票指标公式 -> 通达信指标公式
通达信:盯盘分时主图指标公式
[  时间:2020-05-10 23:29:39   浏览:0次 ]

MA30:=EMA(CLOSE,30);
强弱:=EMA(CLOSE,900);
{-------------------------------------------------------------------------------------}
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:L1+P1*7/8,COLORLIMAGENTA,DOTLINE;
支撑:L1+P1*0.5/8,COLORCYAN,DOTLINE;
中:(支撑+阻力)/2,COLORLIGRAY,POINTDOT;
均价:=SUM(V*C,0)/SUM(V,0),COLORYELLOW,DOTLINE;
现价:=CLOSE,COLORWHITE,LINETHICK1;
DRAWTEXT(ISLASTBAR AND 现价,现价,STRCAT('←',CON2STR(现价,2))),COLORYELLOW;
STICKLINE(CROSS(支撑,现价),支撑,中,0,-1),COLORYELLOW;
STICKLINE(CROSS(现价,阻力),阻力,中,0,-1),COLORGREEN;
DRAWTEXT(LONGCROSS(支撑,现价,2),C*0.9982,' 买'),COLORYELLOW;
DRAWTEXT(LONGCROSS(现价,阻力,2),C*1.0018,' 卖'),COLORCYAN;
STICKLINE(C<支撑,支撑,C,1,0),COLORYELLOW;
DRAWICON(CROSS(支撑,现价),(支撑-中)/5+支撑,26);
{DRAWICON(CROSS(现价,阻力),阻力-(支撑-中)/5,15);}
DRAWTEXT(CURRBARSCOUNT=8,阻力+0.003,'顶'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=8,支撑-0.003,'底'),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=8,(支撑+阻力)/2,'中'),COLORLIRED;
{--------------------}
量价:=(VOL/CLOSE)/3;
A2:=SUM((IF(((量价>0.20) AND (CLOSE>(REF(CLOSE,1)))),量价,0)),0);
A3:=SUM((IF(((量价>0.20) AND (CLOSE<(REF(CLOSE,1)))),量价,0)),0);
A6:=A2+A3;DD1:=1;比:=A2/A3;
AAA1:=STRCAT(STRCAT('买= ',CON2STR((100*A2)/A6,0)),'%');
AAA2:=STRCAT(STRCAT('卖= ',CON2STR((100*A3)/A6,0)),'%');
AAA3:=STRCAT(STRCAT('差= ',CON2STR((100*(A2-A3))/A6,0)),'%');
中期线:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4)+100;
DRAWTEXT(比<1.1,中,'O'),COLORGREEN;
DRAWTEXT(比>1.5,中,'O'),COLORCYAN;
DRAWTEXT(比>2,中,'O'),COLORMAGENTA;
DRAWTEXT(比>2.5,中,'O'),COLORRED;
DRAWTEXT((比>1.1 AND 中期线<5),中,'O'),COLORWHITE;
DRAWTEXT((比<1.1 AND 中期线>98.0),中,'O'),COLORWHITE;
DRAWTEXT((比>1.1 AND 中期线<5),C,'-买'),COLORYELLOW;
DRAWTEXT((比<1.1 AND 中期线>98.0),C,'-卖'),COLORYELLOW;
{-------------------------------------------------------------------------------------}
均价1:=SUM(C*V,240)/SUM(V,240),COLORYELLOW,LINETHICK1;
TT:=BARSCOUNT(C);均:=MA(C,TT);
上均线:=均+2*STD(C,3);下均线:=均-2*STD(C,3);
时长:=TIME>93000;涨幅:=C/REF(C,1)>1.02;跌幅:=C/REF(C,1)<0.98;
横盘:=((HHV(C,TT)-LLV(C,TT))/C)<0.05;YY:=SMA(VOL,30,1);
放量:=(YY-LLV(LLV(YY,1),30))/(HHV(HHV(YY,1),30)-LLV(LLV(YY,1),30))>0.95;
涨跌幅:=涨幅 OR 跌幅;
横涨1:=涨跌幅=0 AND 横盘 AND 放量 AND CROSS(均价1,均);
DRAWTEXT(FILTER(横涨1,10),均价1,'--突破'),COLORCYAN;
DRAWICON(FILTER(横涨1,10),均价1,1);
XX:=SUM(AMOUNT,BARSCOUNT(CLOSE))/SUM(V*100,BARSCOUNT(CLOSE));
主力:=EXPMA(CLOSE/XX,20);大户:=EXPMA(CLOSE/XX,60);散户:=EXPMA(CLOSE/XX,120);
底:=1;1.02,NODRAW;高:=1.03;
AA:=主力>大户 AND 主力>1.003 AND 大户>散户 AND C>EXPMA(C,20) AND EXPMA(C,10)>EXPMA(C,20) AND EXPMA(C,20)>EXPMA(C,60);
DRAWICON(主力>大户 AND 大户>散户 AND C>EXPMA(C,20) AND EXPMA(C,10)>EXPMA(C,20) AND EXPMA(C,20)>EXPMA(C,60) AND 主力=HHV(主力,30) AND CROSS(主力,1.003),C,25);
DRAWTEXT(主力>大户 AND 大户>散户 AND C>EXPMA(C,20) AND EXPMA(C,10)>EXPMA(C,20) AND EXPMA(C,20)>EXPMA(C,60) AND 主力=HHV(主力,30) AND CROSS(主力,1.003),C*0.999,'-主力'),COLORYELLOW;
DRAWICON(CROSS(主力,1.02),C,26);
DRAWTEXT(CROSS(主力,1.02),C*0.999,'-拉升'),COLORCYAN;
DRAWICON(CROSS(主力,1.04),C,24);
DRAWTEXT(CROSS(主力,1.04),C*0.999,'-冲涨停'),COLORLIMAGENTA;
DRAWICON(CROSS(散户,主力),C,6);
DRAWTEXT(CROSS(散户,主力),C*0.9995,'-小心'),COLORGREEN;
DRAWICON(CROSS(散户,大户),C,6);
DRAWTEXT(CROSS(散户,大户),C*0.9995,'-走弱'),COLORGREEN;
{-------------------------------------------------------------------------------------}
现手买:BUYVOL*DYNAINFO(7)*100/10000 COLOR0000FF,NODRAW;
现手卖:SELLVOL*DYNAINFO(7)*100/10000 COLOR00FF00,NODRAW;
合:=ABS(现手买)+ABS(现手卖)COLOR80FFFF,NODRAW;
差:=ABS(现手买)-ABS(现手卖)COLOR80FFFF,NODRAW;
MPB1:=ABS(现手买)/合*100;
MPB2:=ABS(现手卖)/合*100;
TESTSKIP(NOT(现手买 OR 现手卖 OR 合 OR 差 OR MPB1 OR MPB2)!=0);
DRAWRECTREL(595,1000,795,940,RGB(0,128,0));
DRAWRECTREL(595,995,795,945,RGB(0,148,0));
DRAWRECTREL(595,990,795,950,RGB(0,168,0));
DRAWRECTREL(595,985,795,955,RGB(0,188,0));
DRAWRECTREL(595,980,795,960,RGB(0,208,0));
DRAWRECTREL(595,975,795,965,RGB(0,228,0));
DRAWRECTREL(595,970,795,970,RGB(0,248,0));
DRAWRECTREL(595,1000,595+现手买*210/合,940,RGB(128,0,0));
DRAWRECTREL(595,995,595+现手买*210/合,945,RGB(148,0,0));
DRAWRECTREL(595,990,595+现手买*210/合,950,RGB(168,0,0));
DRAWRECTREL(595,985,595+现手买*210/合,955,RGB(188,0,0));
DRAWRECTREL(595,980,595+现手买*210/合,960,RGB(208,0,0));
DRAWRECTREL(595,975,595+现手买*210/合,965,RGB(228,0,0));
DRAWRECTREL(595,970,595+现手买*210/合,970,RGB(248,0,0));
DRAWRECTREL(595+现手买*210/合,940,595+现手买*210/合,1000,RGB(128,0,0));
DRAWRECTREL(795,940,795,1000,RGB(0,0.0,10));
DRAWRECTREL(594.8,939.8,594.8,1000,RGB(0,0,10));
DRAWRECTREL(594.8,939.8,594.8,939.8,RGB(0,0,10));
DRAWRECTREL(594.8,1000,594.8,1000,RGB(0,0,10));
DRAWTEXT_FIX(1,0.560,0.89,0,STRCAT(STRCAT('',CON2STR(现手买,1)),'万')),COLORRED;
DRAWTEXT_FIX(1,0.800,0.89,0,STRCAT(STRCAT('',CON2STR(现手卖,1)),'万')),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(差)>0,0.678,0.888,0,STRCAT(' ',STRCAT(CON2STR(差,1),'万'))) COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(差)<0,0.678,0.888,0,STRCAT(' ',STRCAT(CON2STR(差,1),'万'))) COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(差)=0,0.678,0.888,0,STRCAT(' ',STRCAT(CON2STR(差,1),'万'))) COLOR80FFFF;
DRAWTEXT_FIX(1,0.800,0.98,0,STRCAT(STRCAT(' ',CON2STR(MPB2,1)),'%')),COLORGREEN;
DRAWTEXT_FIX(1,0.560,0.98,0,STRCAT(STRCAT('',CON2STR(MPB1,1)),'%')),COLORRED;
{-------------------------------------------------------------------------------------}
D1:=YEAR AND MONTH AND DAY;
AA1:=STRCAT(CON2STR(YEAR,0),'年');
AA2:=STRCAT(CON2STR(MONTH,0),'月');
AA3:=STRCAT(CON2STR(DAY,0),'日');
AA4:=STRCAT('星期',IF(WEEKDAY=1,'一',IF(WEEKDAY=2,'二',IF(WEEKDAY=3,'三',IF(WEEKDAY=4,'四',IF(WEEKDAY=5,'五',IF(WEEKDAY=6,'六','日')))))));
AAC:=STRCAT(STRCAT(STRCAT(AA1,AA2),STRCAT(AA3,AA4)),'');
DRAWTEXT_FIX(D1,0.888,0.001,0,AAC),COLORLIGRAY;
{-------------------------------------------------------------------------------------}
MZ0:=(BARSLAST(((HOUR=9) AND (MINUTE=31)))+1);
上穿分时:IF(((SETCODE<2) AND (CONST(MZ0)<241)),CONST(IF((TIME<1000),HHV(CLOSE,0),SUM((IF((TIME=1000),1,0)*HHV(CLOSE,0)),0))),DRAWNULL),LINETHICK1,COLORLIRED;
底支:IF(((SETCODE<2) AND (CONST(MZ0)<241)),CONST(IF((TIME<1000),HHV(CLOSE,0),SUM((IF((TIME=1000),1,0)*LLV(CLOSE,0)),0))),DRAWNULL),LINETHICK1,COLORLIGREEN;
STICKLINE(TIME=931 OR TIME=1000,上穿分时,底支,0,-1),COLORLIBLUE;
分时上突:=CROSS(C,上穿分时);
上突:=C<上穿分时 AND 上穿分时>底支;
股价支撑线:=MA(CLOSE,20);
底价线:=股价支撑线-2*STD(CLOSE,20),COLORMAGENTA,LINETHICK2;
VAR106:=BARSCOUNT(CLOSE);
VAR107:=MAX(DYNAINFO(3),DYNAINFO(5));
VAR108:=MIN(DYNAINFO(3),DYNAINFO(6));
VAR109:=VAR107-VAR108;
VAR110:=VAR108+VAR109*7/8;
VAR111:=VAR108+VAR109*0.5/8;
DRAWICON(LONGCROSS(VAR111,CLOSE,2),CLOSE,1);
DRAWICON(LONGCROSS(CLOSE,VAR110,2),CLOSE,2);


上面就是小编为您带来通达信:盯盘分时主图指标公式的全部内容。

股票学习 下一篇:通达信:新资金缩放量指标公式
本栏目最新文章
栏目导航

最新文章 | 网站地图 | | dddcun@163.com

今日股市大盘行情、股票入门基础知识学习、股票学习、股票内参、股票公式、等最新资讯。晋ICP备16003067号-3

声明:本站所有数据与资料来自网络,无法确定其真实性,请谨慎参考,造成的任何损失责任自负!股票俱乐部